Process Mapping Logo

Process Mapping - Forums

Sharing 19 years of knowledge and experience

 
Metastorm BPM forums
Sign up Latest Topics
 
 
 


Reply
  Author   Comment  
suityou01

Avatar / Picture

Veteran
Registered:
Posts: 213
Reply with quote  #1 
Hi,

I just flamed my dev environment. I was running 9.2.

So I installed :

9.2.0.1
9.2.1.1
9.2.1.2

And that has trashed my dev environment. When I go to localhost/metastorm I can see the menu bar, the links for do list, watch list, blank forms etc but rather than be greeted by the login screen below I just get this message

Object reference not set to an instance of an object.

Also the deployment service won't start now. I get this message in the event log :

Exception message: Unable to start the Deployment Service because the target database schema is not compatible. The schema version is '9.2.0.0', but the expected schema version is '9.2.1.0'.



A smoking gun at least.


But I checked the patches and none of them contain a seperate script file for running against the database. So if applying the patches doesn't roll the database forward, what does?

Any help appreciated.
0
BMellert

Guru
Registered:
Posts: 688
Reply with quote  #2 
I ended up doing a fresh install of 9.2.0.0, then applying 9.2.1.0 then 9.2.1.1.  (I haven't yet applied 9.2.1.2 since it just came out.)  I had to start with a fresh install of 9.2.0 since I couldn't "step" from 9.1.2.x to 9.2.0 to 9.2.1.0 as the last always failed during the upgrade.

However, with this installation I have had not issues -- particularly not what you are describing.
Did you run the database scripts (under Engine\Database and AdministrativeToold\Database) after the final install/patch was complete?  I'd do so even if the dates on the files do not appear to have changed.  Even if you did, I'd run them again as it sounds like that is what your issues are related to.
0
suityou01

Avatar / Picture

Veteran
Registered:
Posts: 213
Reply with quote  #3 
Thanks BMellert. I don't have the path "Engine\Database and AdministrativeToold\Database" in my installation. Could you have misquoted it?

Which scripts should I run, and where is the precise path?

<wonders why this wasn't mentioned in any of the release notes>
0
Jerome

Avatar / Picture

Guru
Registered:
Posts: 5,507
Reply with quote  #4 
I think these are in:
C:\Program Files (x86)\Metastorm\BPM\Engine\Database

The admin tools one is:
C:\Program Files (x86)\Metastorm\BPM\Administrative Tools\Database

This should be mentioned in the installation guide.

__________________
Post an example, and we will have a much better idea what the problem is. In about 90% of posts, the problem is one of communication. Examples bridge that gap.
0
JoeOmerta

Veteran
Registered:
Posts: 210
Reply with quote  #5 
They don't' mention anything in the release notes other than "follow original installation guide".  I've been bit by this a few times but now i know what to look for.  I do like how 9.2 started backing up all the web.config and engine config files during an upgrade.

Also, after running the scripts BMellert and Jerome mentioned, if you're still having an issue you might need to remove/re-add any authentication scripts(eUser.js, eSSO_web.js, etc...)
0
chernoa

Member
Registered:
Posts: 14
Reply with quote  #6 
We are having problems as well. Action form displays data in ListBox, but the same stage form DOES NOT!
0
Jerome

Avatar / Picture

Guru
Registered:
Posts: 5,507
Reply with quote  #7 
Read-only list boxes only display the selected values, not the option list. This has been that way going back to version 4.
__________________
Post an example, and we will have a much better idea what the problem is. In about 90% of posts, the problem is one of communication. Examples bridge that gap.
0
chernoa

Member
Registered:
Posts: 14
Reply with quote  #8 
Jerome, thanks!!! I use grids usually, but tried to reduce the page load... Back to grids now :):)
0
Previous Topic | Next Topic
Print
Reply

Quick Navigation:


Create your own forum with Website Toolbox!