Process Mapping Logo

Process Mapping - Forums

Sharing 19 years of knowledge and experience

 
Metastorm BPM forums
Sign up Latest Topics
 
 
 


Reply
  Author   Comment  
rdorfman

Member
Registered:
Posts: 47
Reply with quote  #1 
I need to know the correct syntax for a URL that will initiate a new Blank Form for a specific map under SSO.

According to the Web Author's Guide, this is the URL to open a new blank form for a specific map.
http://<Web Server>/< Web Extensions Virtual Directory
Alias>
/eForm.aspx?Map=<Metastorm Map
Name>
&Client=External[&Action=<Action Name>]

Based on that I constructed the following URL, where my map name "DealRequest_P".

http://spaewk03-v/MetastormSSO/eForm.aspx?Map=DealRequest_P&Client=External

The url worked perfectly, except that it prompted me for my user id/pass. Once I entered those, a new blank form opened.
There is some urgency to this as I have a user demo coming up tomorrow and would like to have this feature ready if possible.
Thanks - Ron
e-Work version: 7.5 SP1
Database: MS Sql Server2000 Version:8.00.760(SP4)
Both engine and web are on Windows 2003
Client: Internet Explorer v:6.0.2800.1106CO

__________________
Ron Dorfman - Workflow Development Manager
Morrison | Foerster LLP
(415) 268-6572
0
bigfootger

Veteran
Registered:
Posts: 139
Reply with quote  #2 
Hi Ron,

try that URL construct:

http://<webserver>/MetastormSSO/eexternalform.asp?service=<service>&redirect=<MetastormURL>

 

Your Url would then look like:

http://spaewk03-v/MetastormSSO/eexternalform.asp?service=Metastorm%20BPM%20Server&redirect=http://spaewk03-v/MetastormSSO/eForm.aspx?Map=DealRequest_P&Client=External

 

That should work.

 

Best regards

 

Sascha Cutura
scutura@idtsolutions.co.uk

IDT | OPTIMISING BUSINESS PROCESS

t:
+44 (0)1707 294600 | m: +44 (0)7825 712672 | f: +44 (0)1707 294601

Attimore Barn, Ridgeway, Welwyn Garden City, Herts, AL7 2AD, UK

 

 

 


__________________
Metastorm BPM Remote Expert Help & Web Consultations - http://connect.convedo.com/free-1-hour-web-consultation
0
rdorfman

Member
Registered:
Posts: 47
Reply with quote  #3 
Sascha,
I made one small change in what you sent - in the redirect as the location of eForm.aspx is under "/Metastorm", not "/MetastormSSO".  Once I changed that, it worked perfectly.

You saved the day for me! 
thanks
Ron

__________________
Ron Dorfman - Workflow Development Manager
Morrison | Foerster LLP
(415) 268-6572
0
Previous Topic | Next Topic
Print
Reply

Quick Navigation:


Create your own forum with Website Toolbox!