Process Mapping Logo

Process Mapping - Forums

Sharing 19 years of knowledge and experience

 
Metastorm BPM forums
Sign up Latest Topics
 
 
 


Reply
  Author   Comment  
Jas

Senior Veteran
Registered:
Posts: 429
Reply with quote  #1 
We've restored our production database to a new server and ran a SQL script to do a find and replace on the old server name in the db. However, the deployed solutions that use connections to other databases are still holding the old server name as part of the connection string.

Is anyone aware of any way to resolve this without having to redeploy all libraries and projects or modifying the connections for each project through the admin portal?

Thx
Jas
0
BMellert

Guru
Registered:
Posts: 688
Reply with quote  #2 
When you change servers/database/user/password, you also need to edit the registry settings and ODBC connection for the new information.  The registry is HKEY_LOCAL_MACHINE | SOFTWARE | Wow6432Node | Metastorm | e-work | Engine | Database.  You should probably also update ... | Engine | Database Connection | Oracle DBC (or SQL Server DBC depending on database being used).  I'd also suggest updating ... | e-work | InstallInfo as well in case a repair is ever needed.
0
Jas

Senior Veteran
Registered:
Posts: 429
Reply with quote  #3 
I should have said that we created a new BPM and db server to upgrade from 9.1 to 9.4. The registry etc is fine just the non default Metastorm connections defined in libraries and solutions that needed to be changed (would have thought they were held in one of the tables somewhere). I decided to update the connections through the admin portal but just started testing one of processes i'm now getting Object reference not set to an insatnce of an object errors where serverside scripts are used so may have to redeploy anyway :'(
0
praxkan

Veteran
Registered:
Posts: 142
Reply with quote  #4 
Library connections are compiled "inline" when you deploy a procedure - so there shouldnt be a need to redeploy libraries. If the connection itself is an issue, overriding in metastorm admin should work.

Is your old DB still online? Maybe the admin somehow is still connecting to the old DB and making changes there ? (eConnection) Try taking the old DB offline and see if metastorm admin still works.
0
Previous Topic | Next Topic
Print
Reply

Quick Navigation:


Create your own forum with Website Toolbox!