Process Mapping Logo

Process Mapping - Forums

Sharing 19 years of knowledge and experience

 
Metastorm BPM forums
Sign up Latest Topics
 
 
 


Reply
  Author   Comment  
Jerome

Avatar / Picture

Guru
Registered:
Posts: 5,507
Reply with quote  #1 

Engine Doesn't Start After Upgrade

Last edited: 05 Aug 2005


The information in this article applies to product: e-Work 6.x

Issue

  • After e-Work has been upgraded to a newer version or after a hotfix                                         has been applied, attempts to start the Engine service generate one of the following error messages:

    "The e-Work Engine service on Local Computer started and then stopped. Some services stop automatically if they have no work to do, for example, the Performance Logs and Alerts service."

    "Could not start the e-Work Engine service on Local Computer. The service did not return an error. This could be an internal Windows error or an internal service error. If the problem persists, contact your system administrator."

Resolution

  • Run the new e-Work stored procedures against the database. These can be found at <drive>:\Program Files\Metastorm e-Work\Engine\Database. For SQL Server, run eWorkProcedures.sql. For Oracle, run eWorkTypes.sql, eWorkPackage.sql, and eWorkProcedures.sql in that order. See the e-Work Installation Guide for more details.

    If the Engine still won't start, verify that the correct database connection details are in the registry here:

    HKEY_LOCAL_MACHINE\SOFTWARE\Metastorm\e-work\Engine\Database
    and
    HKEY_LOCAL_MACHINE\SOFTWARE\Metastorm\e-work\Engine\Database Connectors

    See Related Articles for additional information that may apply.

Keywords: kb540


__________________
Post an example, and we will have a much better idea what the problem is. In about 90% of posts, the problem is one of communication. Examples bridge that gap.
0
Previous Topic | Next Topic
Print
Reply

Quick Navigation:


Create your own forum with Website Toolbox!