Process Mapping Logo

Process Mapping - Forums

Sharing 19 years of knowledge and experience

 
Metastorm BPM forums
Sign up Latest Topics
 
 
 


Reply
  Author   Comment  
JBudler

Member
Registered:
Posts: 17
Reply with quote  #1 
Hi Guys,

I am getting the following error in the event logs and am not sure how to trouble shoot it, any guidance?

Action: IMcommonverifyasgnVerifyAssign
FolderID: 0900000000000000000000000036939
Map: prcIncidentManagement
IsFolderAction: True
Service: Metastorm BPM Server
CacheToken: 617b9c89164e4d9189bca42d9c1fa1a8
Error Message: Exception of type 'Metastorm.Engine.Interface.SessionInvalidException' was thrown.
Stack Trace:    at Metastorm.ECL.ECLSession.StartAction(String folderID, String mapName, String actionName, Boolean commitNow, Collection`1 actionData, Nullable`1 clientTimeZoneOffset, Int32 version)
   at Metastorm.Web.Forms.Form.ProcessForm(FormProcessInfo processingInfo)
   at Metastorm.Web.Forms.Form.OnLoad(EventArgs e)
   at System.Web.UI.Control.LoadRecursive()
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

Not sure why the session would be invalid when we are using SSO.

Regards,
Jacques

__________________
Regards,
Jacques
0
Techno

New Member
Registered:
Posts: 4
Reply with quote  #2 
Hi Jacques

I know this is an old thread, but can you remember if you were able to figure out why you got the error you mentioned above?

We're getting the same thing on two Prod Metastorm servers, configured with a load balancer and connected to the same database. So it seems like it has to be something with the database or the connection between the MBPM servers and the DB.

The users got the classic "No Engines available..." message when clicking on something. Seems like a Process Engine restart did the trick, but it's still concerning. I would like to sort out whatever caused this to avoid it in future.

Regards,
Techno
0
BMellert

Guru
Registered:
Posts: 688
Reply with quote  #3 
I wish we were getting something on the MBPM servers.  We've had users getting this off and on and we've had an open OT ticket for 14 months now to no avail.  We don't get that in the server logs, the user gets this message on their end and they lose all edits.

They have recently provided us an DLL update which may capture additional logs, but we'll have to wait and see.  (Nothing has been logged in our QA environment since I put it in and we put it into production tonight.)
0
Techno

New Member
Registered:
Posts: 4
Reply with quote  #4 
Ok so I contacted the OpenText support guys about this. We got it resolved by doing the following steps:
  • Set the Session Timeout to 1440 (24 hrs)
  • Clear the eSession table
  • Restart the process engine(s)
Seems like these steps have resolved the issue in the Event Logs. We're using Portal with MBPM Portlets as a front end to the users, so it seems like these portlets keep the session open for longer.
0
Previous Topic | Next Topic
Print
Reply

Quick Navigation:


Create your own forum with Website Toolbox!