Process Mapping Logo

Process Mapping - Forums

Sharing 19 years of knowledge and experience

 
Metastorm BPM forums
Sign up Latest Topics
 
 
 


Reply
  Author   Comment  
Jerome

Avatar / Picture

Guru
Registered:
Posts: 5,507
Reply with quote  #1 

The information in this article applies to product: e-Work 6.6.2

Issue

  •                                 Attempting to log in to e-Work through the web extensions fails                                 when SharePoint Server and the e-Work web extensions are on the same server.                                
  •                                 If "Show friendly HTTP error messages"                                 is not enabled in Internet Explorer, an error similar to the following may be displayed in the browser:

                                    Description: An error occurred during the processing of a configuration file required to service this request.
                                    Please review the specific error details below and modify your configuration file appropriately.
                                    Parser Error Message: There is no 'FormsAuthentication' module in the application to remove.
                                    Source Error:
                                            Line 23: <httpModules>
                                            Line 24: <remove name="FormsAuthentication"/>
                                            Line 25: <remove name="WindowsAuthentication"/>
                                            Line 26: <remove name="PassportAuthentication"/>
                                            Source File: C:\Program Files\Metastorm e-Work\Web6\eweb\web.config
                                            --------------------------------------------------------------------------------
                                            Version Information: Microsoft .NET Framework Version:1.1.4322.573; ASP.NET Version:1.1.4322.1085

                                           
  •                                         A message similar to the following may be written to the Windows event log:

                                            Security Exception
                                            Description: The application attempted to perform an operation not allowed by the security policy.                                         To grant this application the required permission please contact your system administrator                                         or change the application's trust level in the configuration file.                                         Exception Details: System.Security.SecurityException:                                         Request for the permission of type System.Security.Permissions.FileIOPermission, mscorlib, Version=1.0.5000.0,                                         Culture=neutral, PublicKeyToken=b77a5c561934e089 failed.                                        

Resolution

  •                                 Open the file web.config in a text editor such as Notepad.                                 The default location of this file is C:\Program Files\Metastorm e-Work\Web6\eweb.                                
    1.                                 Comment out the tag <httpModules>.                                
    2.                                 Add <trust level="Full" originUrl="" /> under the <system.web> tag.                                
                                   
  •                                 The resulting <system.web> tag should be similar to this:

                                            <system.web>
                                            <!--
                                            <httpModules>
                                            <remove name="FormsAuthentication"/>
                                            <remove name="WindowsAuthentication"/>
                                            <remove name="PassportAuthentication"/>
                                            <remove name="Session"/>
                                            </httpModules>
                                            -->
                                            <httpRuntime maxRequestLength="40000" executionTimeout="180"/>
                                            <authentication mode="None"/>
                                            <sessionState mode="Off"/>
                                            <pages buffer="true" enableViewState="false"/>
                                            <compilation defaultLanguage="c#" debug="false"/>
                                            <customErrors mode="Off"/>
                                            <trace enabled="true" requestLimit="10" pageOutput="false" traceMode="SortByTime" localOnly="true"/>
                                            <globalization requestEncoding="utf-8" responseEncoding="utf-8"/>
                                            <trust level="Full" originUrl="" />
                                            </system.web>                                

__________________
Post an example, and we will have a much better idea what the problem is. In about 90% of posts, the problem is one of communication. Examples bridge that gap.
0
Previous Topic | Next Topic
Print
Reply

Quick Navigation:


Create your own forum with Website Toolbox!