Process Mapping Logo

Process Mapping - Forums

Sharing 19 years of knowledge and experience

 
Metastorm BPM forums
Register Latest Topics
 
 
 


Reply
  Author   Comment  
suityou01

Avatar / Picture

Veteran
Registered:
Posts: 213
Reply with quote  #1 
Hi,

I have a process (inherited) that launches an admin form from a hyperlink the user clicks on.
The hyperlink is constructed "on click" to add some sort of query string to the end of the base url.

The querystring looks like this "&FilterParams=CustomerId;680;Integer:FT_FolderId;;Text"

I believe this passes the CustomerId to the admin form, and the admin form "automagically" assigns the value to the local variable of the same name. Apparently this is a new feature of 9.3.2.2.

My problem is that it doesn't successfully pass the value to the admin form. This is on a brand new V9 environment I just built, again 9.3.2.2.

The same code works on the other inherited environments, so could I be missing a configuration step? I followed the install instructions in the install guide, and have build hundreds of v9 boxes in the past.

Does anyone use this functionality, and or had difficulties in getting it to work?
0
BMellert

Guru
Registered:
Posts: 672
Reply with quote  #2 
Check the $BPMHOME$/Web/web.config for setting

<addkey="AllowFilterParams"value="true"></add>

It should be true for the parameters to be accepted.  If missing or false, the passed in values will not be assigned.
This works for passing values to both forms and reports.

<addkey="AllowFilterParams"value="true"></add>

0
Previous Topic | Next Topic
Print
Reply

Quick Navigation:


Create your own forum with Website Toolbox!