Process Mapping Logo

Process Mapping - Forums

Sharing 19 years of knowledge and experience

 
Metastorm BPM forums
Sign up Latest Topics
 
 
 


Reply
  Author   Comment  
swa

Member
Registered:
Posts: 23
Reply with quote  #1 
Hi,
I've already upgraded my designer version to v9.2.
Is there any option to import dll references compiled in .net v.4.0?
0
praxkan

Veteran
Registered:
Posts: 142
Reply with quote  #2 
If you want DLL references in designer, you just need to copy the dll's inside Designer\CustomLib folder
0
swa

Member
Registered:
Posts: 23
Reply with quote  #3 
Quote:
Originally Posted by praxkan
If you want DLL references in designer, you just need to copy the dll's inside Designer\CustomLib folder

Yes it's obvious but designer allows importing only .net 2.0/3.5 compiled dlls.
As I wrote, I need support for .net v4.0 dlls.
Do you have any ideas/clues how to turn it on?
0
homar

New Member
Registered:
Posts: 2
Reply with quote  #4 
Hi,
We came across similar problem a while ago where we wanted to use functionality of .NET Framework 4.5 to communicate with SAP webservice.
What was advised by Metastorm support was to create a skeleton on the designer custom lib side with an engine dll containing the .NET 4.5 logic, with matching parameters.
There is a limitation here - if your functions would use .Net4+ type parameters that don't exist in .Net 3.5, it won't work. It was not a case in our scenario and we successfully implemented this method.
Hope it helps.
0
swa

Member
Registered:
Posts: 23
Reply with quote  #5 
it's ridiculous. if I had only one or two methods I would cope. It's no option for me.
Maybe do you have better than opentext's advice?
0
swa

Member
Registered:
Posts: 23
Reply with quote  #6 
funny thing - code doesn't validate in the designer, intellisense doesn't show any .net 4 classes, but everything properly deploys to the engine.
As of yet maintaining solutions was a really challenge. Now I'm speechless.
0
swa

Member
Registered:
Posts: 23
Reply with quote  #7 

Finally I've enabled .net 4.0 in the designer.
With some limitations it's possible to include dlls and work with intellisense and validation.

0
Previous Topic | Next Topic
Print
Reply

Quick Navigation:


Create your own forum with Website Toolbox!