Process Mapping Logo

Process Mapping - Forums

Sharing 19 years of knowledge and experience

 
Metastorm BPM forums
Sign up Latest Topics
 
 
 


Reply
  Author   Comment  
montesj

Member
Registered:
Posts: 41
Reply with quote  #1 
Hi All,

Server Details:
OS: Windows Server 2008 R2 Enterprise
Metastorm Version : 9.1.2.2
SMTP : Installed on IIS 6

We have currently upgraded out acceptance server to Metastorm 9.1.2.2
from 9.0.3.3 version. Sending email on the previous version using Mtsm.SendEmail function does not have any errors when sending on our solution, but when we upgraded, errors where encountered and has not been successful in sending.


Here are the details of the error from eLog:
eDetails: Mailbox unavailable. The server response was: 5.7.1 Unable to relay for xxx@xxx.com

eStackTrace:   
at System.Net.Mail.SendMailAsyncResult.End(IAsyncResult result)     at System.Net.Mail.SmtpTransport.EndSendMail(IAsyncResult result)     at System.Net.Mail.SmtpClient.SendMailCallback(IAsyncResult result)

Looking at the release note for the 9.1.2.2 there was a change on the SMTP.
"CDONTS Replaced with SMTP Email - The CDONTS library for sending e-mails via ‘Send E-Mail’ activity will be replaced with the .NET SMTPClient."

Is there any configuration that we need to configure or code change that we need to implement inorder to send emails again from BPM?

If you have any questions or clarification that may help on this please let me know.

Please advise.

Regards
JB
0
Jerome

Avatar / Picture

Guru
Registered:
Posts: 5,507
Reply with quote  #2 
You have to replace all your send email visual script activities, I think.

__________________
Post an example, and we will have a much better idea what the problem is. In about 90% of posts, the problem is one of communication. Examples bridge that gap.
0
powerplay

Avatar / Picture

Senior Member
Registered:
Posts: 77
Reply with quote  #3 
Hi montesj,

What changes you made to resolve the issue.

I am also facing similar issue in the solution.


Thanks

__________________
Thanks
HB
0
hussaini

Member
Registered:
Posts: 22
Reply with quote  #4 
Hello montesj,

Just wanted to check what changes you had made to fix the mentioned issue?

Even i am facing a similar issue.

Regards,
0
montesj

Member
Registered:
Posts: 41
Reply with quote  #5 
Hello,

Have you tried checking the registry setting for the SMTP under metastorm?
[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Metastorm\e-work\Engine\SMTP]

Maybe you can start there, im not sure but I think that is where our problem was.

I'll try to check my emails for additional info. I'll let you know if I can still find it.

Good Luck!

0
hussaini

Member
Registered:
Posts: 22
Reply with quote  #6 
The registry key SMTP seems to be fine. Its pointed to localhost which in turn relays to smarthost (the actual SMTP server)

The elog table is populated with the following errors.

1) An error occurred while sending email in the background.

2) Syntax error, command unrecognized. The server response was:  

3)  at System.Net.Mail.SmtpConnection.ConnectAndHandshakeAsyncResult.End(IAsyncResult result)     at System.Net.Mail.SmtpClient.ConnectCallback(IAsyncResult result)


The errors seems to be due to syntax error, not really sure (its that's true) how to trace it.

do you have any suggestion on how to track?


Regards,
0
Previous Topic | Next Topic
Print
Reply

Quick Navigation:


Create your own forum with Website Toolbox!