Process Mapping Logo

Process Mapping - Forums

Sharing 19 years of knowledge and experience

 
Metastorm BPM forums
Register Latest Topics
 
 
 


Reply
  Author   Comment  
JazzyJ

New Member
Registered:
Posts: 2
Reply with quote  #1 
Has anyone been able to successfully use System.Data.DataSetExtensions.dll in a project? It doesn't seem to get automatically picked up by the designer as a reference.

I've been able to manually drop in the DLL into the CustomLib/dotnetbin folders and it works fine, but I'd prefer not to do that with a system DLL.

Or am I missing something here?
0
BMellert

Guru
Registered:
Posts: 676
Reply with quote  #2 
At the top of each of our server side scripts is the default "using" statement region, which includes System.Data.  We've added our own here on the few occasions they were needed.  Might this be missing in your scripts?
Code:

#region Using Statement

using System;

using System.Data;

using System.Collections.Generic;

using Metastorm.Ide.Extensibility;

using Metastorm.Runtime.Core;

using Metastorm.Runtime.Types;

using System.ComponentModel;

#endregion Using Statement

 

0
thomas

Senior Member
Registered:
Posts: 79
Reply with quote  #3 
Quote:
Originally Posted by JazzyJ
Has anyone been able to successfully use System.Data.DataSetExtensions.dll in a project? It doesn't seem to get automatically picked up by the designer as a reference.

I've been able to manually drop in the DLL into the CustomLib/dotnetbin folders and it works fine, but I'd prefer not to do that with a system DLL.

Or am I missing something here?


Experiencing the same issue, had to actually drop that dll in the CustomLib, and even then the reference wouldn't pick it up with intellisense, but manually typing it in was fine.
Strange, cause I assume the Designer code is compiling against .net 3.5 which has the DataSetExtensions library? (We can only hope it ever changes)

Have you tried putting it in the GAC?
0
JazzyJ

New Member
Registered:
Posts: 2
Reply with quote  #4 
Quote:
Originally Posted by BMellert
At the top of each of our server side scripts is the default "using" statement region, which includes System.Data.  We've added our own here on the few occasions they were needed.  Might this be missing in your scripts?
Code:

#region Using Statement

using System;

using System.Data;

using System.Collections.Generic;

using Metastorm.Ide.Extensibility;

using Metastorm.Runtime.Core;

using Metastorm.Runtime.Types;

using System.ComponentModel;

#endregion Using Statement




This was in an expression or a condition rather than in a server script.

Quote:
Originally Posted by thomas

Experiencing the same issue, had to actually drop that dll in the CustomLib, and even then the reference wouldn't pick it up with intellisense, but manually typing it in was fine.
Strange, cause I assume the Designer code is compiling against .net 3.5 which has the DataSetExtensions library? (We can only hope it ever changes)

Have you tried putting it in the GAC?


In the end we I just went with CustomLib too.
0
Previous Topic | Next Topic
Print
Reply

Quick Navigation:


Create your own forum with Website Toolbox!